Mengatasi Masalah Plupload version could not be determined


Tidak sedikit kesalahan, kegagalan fungsi ataupun error yang terjadi pada drupal bisa diakibatkan oleh kesalahan Administrator sendiri,  misalnya saja ketika saya mencoba mengaplikasikan module plupload untuk upload banyak gambar sekaligus di drupal. Saya melakukan kesalahan karena tidak membaca dokumentasi dari module yang akan Saya gunakan tersebut, hingga akhirnya terjadi  kegagalan fungsi atau error dari module yang saya instal tersebut.

Lihat juga : Cara Mengatasi Failed to get available update data Drupal

Plupload sendiri digunakan untuk melakukan upload banyak gambar sekaligus, dimana modul ini terdiri dari Plupload integration modul (plupload), IMCE Plupload, FileField Sources Plupload dan Source Plupload yang diunduh dari situs resmi plupload yang selanjutnya ditaruh di sites/all/libraries.

Saat akan mencoba mengupload modul ini Saya kurang membaca dokumentasinya dengan baik, sehingga yang terjadi adalah module ini menyebabkan kegagalan fungsi dari modul IMCE, dimana tombol upload gambar dari IMCE jadi menghilang

tombol upload IMCE menghilang


Ketika terjadi sebuah kegagalan fungsi ataupun error maka kita bisa mengecek hal tersebut pada halaman status report, dan benar saja dalam status report diperlihatkan ada yang bermasalah

status report

Tapi sebenarnya yang bermasalah disana bukanlah modulnya, melainkan source yang ditaruh pada sites/all/libraries. Source tersebut merupakan source code yang didownload dari situs plupload. Versi plupload yang Saya gunakan pada saat itu adalah versi 2.3.1. Bila diperhatikan dari pesan di status report menandakan bahwa versi yang Saya gunakan tidak support lagi.

Mengetahui hal tersebut akhirnya Saya mencoba kembali membaca dokumentasi dari module plupload di drupal, dan ternyata benar saja, versi yang di dukung itu adalah versi 1.5.8 

halaman drupal tentang plupload

Compatibility warning
Library version v2.0.0 and later are currently unsupported. Latest supported version of library is v1.5.8, which can be downloaded from https://github.com/moxiecode/plupload/archive/v1.5.8.zip

Mengatasi Masalah Plupload version could not be determined
  1. Nonaktifkan dulu module – modul FileFiled Source, Plupload integration modul (plupload), IMCE Plupload dan FileField Sources Plupload 
  2. Hapus folder plupload yang berada di sites/all/libraries 
  3. Download source plupload versi 1.5.8 di https://github.com/moxiecode/plupload/archive/v1.5.8.zip 
  4. Taruh plupload versi 1.5.8 di sites/all/libraries 
  5. Setelah itu jangan lupa juga hapus folder “EXAMPLE” yang terdapat pada folder plupload 
  6. Aktifkan kembali modul FileFiled Source, Plupload integration modul (plupload), IMCE Plupload dan FileField Sources Plupload 
  7. Terakhir bersihkan cache (Flush all cache) drupal atau kalau perlu clear cache browser

Bila berhasil, nanti tombol upload dari IMCE akan muncul berikut dengan plupload nya, kemudian nanti pesan Plupload version could not be determined  pada halaman status report juga akan hilang

imce kembali normal dan plupload bisa berjalan

Untuk instalasi dan konfigurasi module plupload bisa dibaca pada artikel berikut ini : Upload Banyak Gambar Sekaligus di Drupal Menggunakan Plupload

0 Response to "Mengatasi Masalah Plupload version could not be determined"

Post a Comment

Silahkan untuk meninggalkan komentar, santai saja dan mulailah berkomentar...